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3D Relief Engraving by MAIGC-7
How to Create NC Data with DeskProto
DeskProto assigns size, depth, starting point, speed and method of engraving 3D model file (STL, DXF, WRL)
created by Rhino, 3D MAX and JewelCad, based on the desired engraving materials, and creates the tool
paths data (NC data), which is the moving paths of engraver.

1) Run Program
After installing the program, click
DeskProto icon on the Desktop to run the program. The window below
will appear and the designated name for each part is as follows:
Menu
Tool

X,Y,Z 축의 방향표시

Operation Area Screen

X, Y, Z-Axis Direction Display

<DeskProto Program Screen>
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2) Open 3D Model File (STL, DXF, WRL)
Click File → Open Geometry in Menu and select 3D model to be engraved. Click “Open” button.

3) View Starting Point and 3D Model Size
◈ View Starting Point
1. Right-click the mouse on the operation area and click “Subjects”.
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2. Select Orientator on workpiece zero point in Subjects in View window and click “OK”. A square block
displaying X, Y, Z axis directions and location of starting point on the loaded 3D model appears.

In DeskProto, all coordinates are calculated based on the starting point.
In short, the starting point becomes the reference point that the engraver operates.

◈ View 3D Model Size Data
Click View → Geometry Information in Menu. Geometry Information window appears at the lower right area to
display 3D model size.

3D Model’s X, Y, Z Axis Direction Size
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4) Select Engraver and Adjust 3D Model Size
Go to Parameters → Edit Part Parameters (geometry). Select the desired engraver and adjust the size of 3D
model.

1. Go to Edit Part Parameters → General. Select the desired engraver (REDT-MAGIC-7) in Machine.

2. Edit X, Y, Z axis ratio values under Transform → “1.Scale” to adjust the size of 3D model.
Scale: Adjust X, Y, Z axis size ratio values

When you uncheck Uniform, you can edit X, Y, Z axis ratio values respectively.
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1. When you edit the size
value in Scale, you can check
the modified size.

5) Assign Location of 3D Model Starting Point and Adjust Engraving Area
◈ Assign Location of Starting Point
Go to Edit Part Parameters → Translate. Assign location of X/Y/Z axis starting point on 3D model.
Translation XY: location of X/Y axis starting point on 3D model
Translation Z: location of Z axis starting point on 3D model

X, Y Starting Point Location

Z Starting Point Location

Although it may vary depending on the user’s preference and starting point of the model assigned
in model design, Translation XY (location of X, Y starting point) selects “To positive X&Y for
part-geometry” and Translation Z (location of Z starting point) selects “Make top of part zero”
as shown in the figure above.

7

◈ Adjust Engraving Area
You can adjust engraving area in 3D model.
1. Go to Edit Part Parameters → Segment. Check “Custom” to select the desired engraving area and click
“Set graphically”.

2. Click
displayed.

in “Set Segment Of Part” if you want to edit the angle that 3D model is

3. The rectangular area surrounding 3D model is the engraving area. You can drag the line by mouse to adjust
the engraving area.
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6) Set Tool and Tool Paths Distance
You can set engraving tools, 3D model tool paths distance and engraving methods.
1. Go to Parameters → Edit Operation Parameters (milling). Edit Operation Parameters window appears.

2. Make the setting as the figure below.
Cutter (tool to be used): set the desired tool
Precision (tool paths distance): set the distance that the tool moves to engrave 3D model
(Set the same values in general)

Engraving time and resolution may vary depending on Cutter (tool to be used) and Precision
(tool paths distance). The smaller the precision (tool paths distance) value is, the higher the
resolution is to increase engraving quality, but this also increases engraving time.
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7) Set Engraving Method
◈Set Engraving Method and Direction
Go to Edit Operation Parameters → Strategy and set engraving method and direction.
Main: select engraving method
Detail Settings, parallel: select engraving direction

Frequently used options are as follows:
Engraving Method: Parallel
Engraving Method: Block

, Engraving Direction: Along X-axis
, Engraving Direction: Inside-Out
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◈Set Z-Axis Roughing
When you engrave a thick 3D model long in Z-axis direction and it is hard to engrave deep depth at once,
you can set Z-Axis Roughing to engrave the concerned depth little by little in several divided times. If you use
Z Roughing and set the appropriate roughing depth based on thickness and tool characteristics of 3D model,
you can ensure stable engraving and prevent tool damage. However, the smaller the roughing setting value,
the longer the engraving time is.
1. Go to Edit Operation Parameters → Roughing.
2. Check “Custom” in Layer height and enter the desired depth that you want to engrave in divided times. The
engraver operates in designated divided times with designated input value and uniform depth.

For example, if you want to engrave 12mm, you can set Custom value as 2mm in Layer height. 2mm
engraving will occur 6 times to reach the targeted depth of 12mm.

8) Create Tool Paths
Go to Create → Calculate Toolpaths. Red tool paths are created on 3D model in operation.
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<Created Tool Paths>

9) Write NC Data File
You can save the tool paths created as NC data file. Go to Create → Write NC-Program to save the file.

.
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3D Ring Engraving b MAGIC-7
How to Create NC Data with DeskProto
DeskProto assigns size, depth, starting point, speed and method of engraving 3D model file (STL, DXF, WRL)
created by Rhino, 3D MAX and JewelCad, based on the desired engraving materials, and creates the tool
paths data (NC data), which is the moving paths of engraver.

1) Run Program
After installing the program, click
DeskProto icon on the Desktop to run the program. The window below
will appear and the designated name for each part is as follows:

Menu
Tool

X,Y,Z 축의 방향표시

Operation Area Screen

X, Y, Z Axis Direction Display

<DeskProto Program Screen >
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2) Open 3D Model File (STL, DXF, WRL)
Click File → Open Geometry and select 3D model to be engraved. Click “Open”.

3) View Starting Point
1. Right click the mouse on the operation area and click “Subjects”.

2. Select Orientator on workpiece zero point in Subjects in View window and click “OK”. A square block
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displaying X, Y, Z axis directions and location of starting point on the loaded 3D model appears.

In DeskProto, all coordinates are calculated based on the starting point.
In short, the starting point becomes the reference point of engraver operation.

4) Select Engraver and Adjust 3D Model Size
Go to Parameters → Edit Part Parameters (geometry). Select the desired engraver and adjust the size of 3D
model.
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1. Go to Edit Part Parameters → General. Select the desired engraver (REDT-MAGIC-7) in Machine and
select Use rotation-axis.

2. When Use rotation-axis is selected, the guideline turns into the cylindrical shape.

3. You can edit X, Y, Z axis ratio values under Transform → “1.Scale” to adjust the size of 3D model. In
addition, you can also adjust rotation angle of Z-axis in “3.Rotation” by editing the rotation angle value of Zaxis.
Scale: adjust X, Y, Z-axis ratio value of 3D model
Rotation: adjust X, Y, Z-axis rotation angle of 3D model
3. Rotation Z : 90 degrees

When you uncheck Uniform, you can edit X, Y, Z axis ratio values respectively.
In this example, the loaded 3D model is rotated by 90 degrees toward Z-axis so that 3D model is facing
toward the cylindrical guideline.
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5) Assign Location of 3D Model Starting Point and Adjust Engraving Area
◈ Assign Location of Starting Point
When you engrave a cylindrical 3D model, such as a ring, Z-axis starting point should be located on
the center of 3D model, as the material is fixed on the rotation axis of the engraver.
Select None under Translation Z in Translate and click “OK”. Starting point is relocated onto the center (when
the model starting point is assigned as center in 3D model design)

◈ Adjust Engraving Area
1. Measure the engraving materials to adjust the inner/outer diameter of 3D model.

A: inner diameter

B: outer diameter

2. Go to Edit Part Parameters → Segment. Check “Custom” to select the desired engraving area and click
“Set graphically”.
3. Click
displayed.

in “Set Segment Of Part” if you want to edit the angle that 3D model is

4. The cylindrical area surrounding 3D model is the engraving area. You can drag the line by mouse to adjust
the engraving area.
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5. When you move the mouse cursor to the center of 3D model, the cursor shape is changed into
click the mouse and drag it upward to adjust the inner diameter.

. Left-

6. Z-axis value, corresponding to A/B in the below figure, should always be a positive number (+). In particular,
the inner diameter of the materials should be accurately measured when you adjust the size of 3D model.

B: outer diameter

A: inner diameter

B

A

Z-axis value corresponding to A in the above figure should be the same as or similar to the inner diameter radius
value, and B should be smaller than the outer diameter radius value. For example, the inner diameter of the material
measured is 15.28mm and its outer diameter is 27.09mm. Therefore, A/ B value should be about 7.6mm, which is the
inner/outer diameter radius value, while B value should be smaller than 13.5mm. If A/B value is different from the size to
be engraved, you can adjust Scale value described in “4) Select Engraver and Adjust 3D Model Size.
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6) Set Tool and Tool Paths Distance
You can set engraving tools, 3D model tool paths distance and engraving direction using Edit Operation
Parameters(milling).
1. Go to Parameters → Edit Operation Parameters(milling). Edit Operation Parameters window appears.

2. Make the setting as the figure below.
Cutter (tools to be used): set the desired tool
Precision (tool paths distance): set the distance that the tool moves to engrave 3D model
(Set the same values in general)

Engraving time and resolution may vary depending on Cutter (tool to be used) and Precision
(tool paths distance). The smaller the precision (tool paths distance) value, the higher the
resolution is to increase engraving quality, but this also increases engraving time.
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7) Set Engraving Method
◈Set Engraving Method and Direction
Go to Edit Operation Parameters → Strategy and set engraving direction.
Main: select engraving method
Detail Settings, parallel: select engraving direction

Frequently used options in 3D ring engraving are as follows:
Engraving Method: Parallel

, Engraving Direction: Along A-axis
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◈Z Roughing Setting
When you engrave a thick 3D model, long in Z-axis direction and it is hard to engrave deep depth at once,
you can set Z-Axis Roughing to engrave the concerned depth little by little in several divided times. If you use
Z Roughing and set the appropriate roughing depth based on thickness and tool characteristics of 3D model,
you can ensure stable engraving and prevent tool damage. However, the smaller the roughing setting value,
the longer the engraving time is.
1. Go to Edit Operation Parameters → Roughing.
2. Check “Custom” in Layer height and enter the desired depth that you want to engrave in divided times. The
engraver operates in designated divided times with designated input value and uniform depth.

For example, if you want to engrave 12mm, you can set Custom value as 2mm in Layer height. 2mm
engraving will occur 6 times to reach the targeted depth of 12mm.

8) Create Tool Paths
Go to Create → Calculate Toolpaths. Red tool paths are created on 3D model in operation.
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<Created Tool Paths>

9) Write NC Data File
You can save the tool paths created as NC data file. Go to Create → Write NC-Program to save the file.
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Engraver Starting Point Setting
1) Starting Point Setting in 3D Relief Engraving
Before starting engraving, you should set the engraver starting point into the same location as the 3D model
starting point (6p ◈ Assign Location of Starting Point). If the engraver starting point is not properly set,
engraving may be made on the undesired location, and in some cases, tools, materials or vise may
get damaged.
Starting point can be set as shown in the figure below, but its location may vary depending on the starting
point assigned in the program on 3D model. The setting reference of X, Y, Z axis starting point is the tip of the
tool.

◈ X, Y-axis starting point setting
1. Press

button move the tool to the plane vise.

2. Press

or

button, move the tool to X-axis starting point.

3. Press

or

button, move the tool to Y-axis starting point.

4. When

pressed, it generates “pi” sound and

3:Set XY->(0, 0)? appears in LCD.

5. When
pressed again for more than 2 seconds, it generates “Pi~piriric” and
appears in LCD and the assigned value is set as the starting point.

Ready

◈ Z-axis starting point setting
1. Press Z-axis
2. When

or

button to make the tool touch the upper area of the material or lower it.
4:Set Z->(0)?

pressed, it generates “pi” sound and

appears in LCD.

3. When
pressed again for more than 2 seconds, it generates “Pi~piriric” and
appears in LCD and the assigned value is set as the starting point.
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Ready

2) Starting Point Setting in 3D Ring Engraving
Before starting engraving, you should set the engraver starting point into the same location as the
3D
model starting point (16p ◈ Assign Location of Starting Point). If the engraver starting point is not
properly set, engraving may be made on the undesired location, and in some cases, tools, materials
or vise may get damaged.
Starting point can be set as shown in the figure below, but its location may vary depending on the starting
point assigned in the program on 3D model. The setting reference of X, Y, Z axis starting point is the tip of the
tool.

◈ X-axis starting point setting
1. Press

button move the tool to the rotation vise.

2. Press

or

3. When

pressed, it generates “Pi” sound and

button, move the tool to X-axis starting point.
3:Set XY->(0, 0)?

5. When
pressed again for more than 2 seconds, it generates “Pi-pirirc” and
in LCD and the assigned value is set as the starting point.

appears in LCD.
Ready

appears

In the case of 3D ring engraving, A-axis (rotation axis) is used instead of Y-axis. As Y-axis is not used,
Y-axis starting point is not assigned.

◈ Z-axis starting point setting
In 3D ring engraving, Z-axis starting point uses the original engraver setting value assigned on the rotation
axis, and therefore, an additional setting of starting point is unnecessary.
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Data Transfer by NC-Spooler
NC-Spooler is the program that sends NC data file created in DeskProto to the engraver.

◈ NC-Spooler Run and Setting
1. Run Magic Art Program and go to Tool → NC-Spooler to open NC-Spooler window.

Menu

NC Data Transfer Start/Stop

Communication Port

[USB]MAGIC #1(COM5)

<NC-Spooler Run Screen>
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2. In the initial NC-Spooler run, communication port between the engraver and the program should be
configured. For communication configuration, go to Tool → Communication Port Configuration and select
Baud 115200 and XON/XOFF as shown in the below figure.

If communication option is not configured correctly in Communication Port Configuration,
files may not be sent or the engraver may stop operating during engraving.

◈ NC Data Transfer
1. Go to File → Add NC data files to open the NC data file saved in DeskProto.
2. Select the file to be open in File Name and click Transmit Selected to send NC data to the engraver.

115200, XON/XOFF

[USB]MAGIC #1(COM5)

You must set the engraver starting point (22p, 23p) before sending NC data.
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◈ Finished Sample
1. 3D Relief Piece

2. 3D Ring Piece
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